Unable to Access Workspace / Environment after changing Nix. Force Recover Mode?

I was trying to install Cocoa pods to do some native building for iOS on my Expo React Native project directly from the IDX CLI. But as always, I managed to screw something.

Essentially I was tinkering with the Nix configuration and I for sure tinkered too hard. There was one instance where I was able to boot the environment in recovery mode but I could not get to that option again.

Can’t tell you how I F***ed it up so hard, nor why. But I did. Honestly It was a few days ago now so I can’t remember much but I think it was some ruby package or dependency missing when trying to install cocoa pods.

Regardless, my environment is in a F***ed up state, and I need help. I’m like, barely proficient enough in TypeScript let alone this VM stuff so I’m hoooooped here boys. Help a brother out.

It would be very helpful if there was a way I could force recovery mode. I tried scouring the internet but it seems IDX is too new. Anyone know of anything? Maybe a special url I can hit or a query string ?

It isn’t the biggest deal. If at the very least there is any place I can get a heads up on how long until this could be remedied. If its like two weeks out or something, I’ll just rewrite some stuff.

It’s just a few things I wrote that I never pushed to my GitHub branch and some folder refactoring that I would like to not have to do again. But like I said, if a fix is more than a week out it would be cool if I could now just so I can start rewriting and not waiting around.

Honestly, the real reason I think that a forced recovery mode feature is nice:
Not because of this F-up, but trust me, I will screw this up again. So, an easy way to unscrew all my screw ups would be super sick!

I know there has been a few others with this issue so I didn’t want to burden the dev team.
I thought that the team released bi-weekly updates on Tuesdays so I was hoping for an update, but to my knowledge none has gone through.

So yeah if anyone knows anything, let me know. Greatly appreciate it in advance!

If anyone from the IDX team reads this. Keep up the amazing work! So far I’m loving using the cloud especially since my laptop runs a bit slow with VS Code running all those plugins.

Also, I know you guys got that iOS simulator on standby for those of us not using flutter…
I know it.

Can’t wait ;p

I should mention, it just stays stuck building environment.

This happened to me as well, seemes to occure when you try and edit envirmental variable.
https://issuetracker.google.com/issues/341319148
Also, I did make a feature request of force Recover Mode

But no one seemes to have voted on it, yet

This is a problem that we are discussing internally how to address. We do want to address this really soon, so stay tuned

1 Like

@gameirozachary - can you please share the contents of your dev.nix file with us? (I do recognize that may be difficult since it will require you to get into the VM in the first place! Do you have a copy by any chance?)

latest one I managed to push to github was the default workspace one. I basically added a ruby nix package but when I tried installing it, something to do with strscan requiring some other dependency showed up. Or maybe it was when I tried using the gem command. Honestly I can’t remember.

I tried seeing if my idx project was tied to some sort of vm or workspace instance on google cloud console. But it isn’t showing up. Is idx not running on a VM? Can I get into the file system there?

Forgive me if I sound dumb asking this, but is there no way to remote ssh into the file system?

I tried seeing if I could cd into the project folder (broken one) from another healthy one but it seems they have separate folder systems.

There isn’t a way currently to be able to do that. Each of your workspaces is isolated from each other and quite often on a different VM altogether.

We are going to ship a fix soon to allow recovery mode when the “Building Environment” step takes too long. That will allow you and others facing this issue a way to get back in your project and get dev.nix back to a working state.

1 Like