How do you fix GitHub auth failures?

I’m getting this on one of my projects:

image

This was working a couple of weeks ago on for this project. Just opened it up again today and this happened.

I ended up using gh auth login and it worked fine. Thought maybe there would be a way to do it like IDX does it initially though.

3 Likes

That is interesting! If I understand this correctly…

The Github workflow worked when you opened the project initially a few weeks ago. When you opened the project today, the auth token expired. Instead of triggering the original Github auth flow, you had to use the command line.

Is that right?

1 Like

That’s correct. … (adding dots to get to 20 characters).

1 Like

@kirupac I just opened another project, it was in the “archived” state, and same thing happened. So maybe this is related to a project getting archived.

1 Like

Oh that is a good data point to have! Let me share this with the team and see what we can do here.

1 Like

It’s for sure due to archiving. Every time I load a workspace that has been archived this happens.

Actually, I just tried it this morning and it asked me for the GitHub auth flow again automatically. So maybe this got fixed?

And nope, it is not fixed. Just unarchived another project and had to gh auth login to get it to work.