Can't test Stripe with IDX since there is a redirect on the public URLs IDX uses

Hi @treeder , iiuc the reason you see a redirect is because IDX does not support unauthenticated http(s) access to services running on your IDX workspace. To make it work you will have to configure stripe webhook url by adding an access token query parameter to the webhook url, e.g. like the following:

1234-workspace-domain.cloudworkstations.dev/some/path?_workstationAccessToken=<ACCESS_TOKEN>.

To get the access token, please read this blog post. Namely you can generate it by running the “Generate access token” command in the IDE.

Please let me know if it helps, thanks

3 Likes