Connecting to IDX through Ipad

Attempting to connect to idx.google.com through my ipad but running into cookies error. Tried all the troubleshooting I can to attempt to get it to work, but no dice. Anyone else get ipad to connect to idx? Thanks

1 Like

Do you have 3P cookies enabled? (We fixed many cases where you don’t need to do this, but I want to check if that resolves it for you first)

Yes, I have done that in both safari and chrome, no luck.

Did you enable cross-site scripting? This seems to be main thing this user tried to get IDX working on the iPad!

https://www.threads.net/@rickycpadilla/post/C7Pb5jJvjxd/?xmt=AQGznl6ILGVgTTmf3Qn3spDrDs4DCaWekecH45OW5oAyvw

Yup. Still didn’t work…

Yup , tried everything from cookies enabling to cross site , even reinstalling and restarting , yet doesn’t work

Thanks for letting us know. Are you all also seeing a warning message when accessing IDX on the iPad? If you do see a warning, is it this one?

Yes! That is the message I am getting on the ipad. Funny enough, I tried my iphone, it works there, just not on the ipad. I will say I am on the latest beta on my ipad, and normal on my iphone if that helps…

1 Like

faced similar issue here in ipad, would be highly appreciate if it can be fixed

Happening to me as well. Also works on iPhone but fails with same message about cookies on iPad. I have tried many browsers (Safari, Chrome, Opera). Same failure. Very frustrating. Why would this work on the iPhone but not iPad?

Any update to this issue?

No, not yet - we are working through some nitty gritty infrastructure changes to allow for this.

For more context, all IDX workspaces are powered by VMs on GCP’s Cloud Workstations. Those have their own URL scheme different than idx.google.com. Securely having this work without requiring 3P cookies to be enabled is one of those things that seems easy on the surface but has a lot of little issues that we need to address from a security and privacy point of view.

We are working through those many little issues. Personally, as an iPad user, I want to get this functionality back as well :slight_smile: